-->

Script update Otomatis Versi Mikrotik




Halo sobat om mike kali ini saya akan membagikan tutorial mikrotik yaitu Script update Otomatis Versi Mikrotiksebuah script kecil yang berfungsi untuk update otomatis Rrouter Boards anda.

  • mengambil file dari router utama yang berisi nomor versi ROS terbaru;
  • mendapatkan nomor versi yang sedang berjalan;
  • mengekstrak nomor versi minor dan mayor dan membandingkannya;
  • jika versi yang diambil dari router utama lebih baru, maka unduh paket gabungan langsung dari mikrotik.com
  • reboot.


Untuk jasa setting mikrotik bisa klik disini gan:

Jasa setting mikrotik murah bergaransi

Pertama-tama Anda harus membuat file yang berisi nomor versi terbaru di router utama.

/file print file="latestVer";

 /file set latestVer.txt content="3.24";

Sekarang kita sudah siap menjalankan Script Routernya

######################################################################### # download and upgrade ######################################################################### # newest version :local lMajor; :local lMinor; # current version :local vMajor; :local vMinor; :local myVer [/system resource get version]; :for i from=0 to=([:len $myVer] - 1) do={ :if ( [:pick $myVer $i] = ".") do={ :set vMajor [:tonum [:pick $myVer 0 $i]]; :set vMinor [:tonum [:pick $myVer ($i + 1) [:len $myVer]]] ; } } :if ($vMajor < 3) do={ :log warning "RouterOS version too old ($vMajor.$vMinor), update script not compatible"; } else={ # detect platform (architecture-name is not available in older 3.x versions) :local platform [/system resource get architecture-name]; # fetch latest version /tool fetch address="172.16.0.1" src-path="latestVer.txt" user="admin" password="" mode=ftp; :local lVer [/file get latestVer.txt content]; :for i from=0 to=([:len $lVer] - 1) do={ :if ( [:pick $lVer $i] = ".") do={ :set lMajor [:tonum [:pick $lVer 0 $i]]; :set lMinor [:tonum [:pick $lVer ($i + 1) [:len $lVer]]] ; } } :if (($vMajor = $lMajor) && ($vMinor < $lMinor)) do={ :local pckgName "routeros-$platform-$lMajor.$lMinor.npk"; /tool fetch address=[:resolve "www.mikrotik.com"] host="www.mikrotik.com" mode=http src-path="download/$pckgName"; /system reboot; } else={ :log info "Upgrade_script: already latest version"; } }

0 Response to "Script update Otomatis Versi Mikrotik"

Post a Comment

Iklan Atas Artikel

Iklan Tengah Artikel 1

Iklan Tengah Artikel 2

Iklan Bawah Artikel